Okay
  Public Ticket #1430696
How to get semitransparent nav bar like this ...
Closed

Comments

  • Travis started the conversation

    http://shopscape.bold-themes.com/application/home/slider-home/#

    I want to get my nav bar to be transparent like this and then follow and be white transparent... i want this pages nav setup but mine is just pure white or pure black and it is not sticky or doesnt follow?

    Any thoughts on why that could be?  

    I feel like I made have changes the height of the bar to accomodate my logo but dont think I did anything else.... still... i looked for the place to fiddle with these settings and couldnt find it.

    Cheers

    Attached files:  6210024F-D6F4-429F-A56B-20F122867F96.png
      2E1309F8-E09F-4507-82EE-C8906C952DA3.png

  •  630
    Support Agent replied

    Hi  Travis,

    The home page in question has alt logo set. This is usually light version of logo (which is supposed to be used on dark backgrounds). The logic is this:

    1. If you do not have Alternative logo defined, main logo will be used in all cases
    2. If you have Alternative logo defined, it will be used on top of the page when Content Below Menu and Sticky Header options are activated. This set up will also change the color of menu and widgets to light.

    Additionally, it has content set to display below menu, and sticky header activated.

    All these noted settings affect the menu to display this way.

    Let us know if this helped.

    Regards, BoldThemes team

    If you like our products please consider leaving us a rating. A huge thank you from BoldThemes in advance!

  • Travis replied

    Excellent!  Got it.... so on a page where the top image is lighter like:

    http://shopscape.bold-themes.com/application/inner-page/features/

    for example

    How do you work around that?  On this page the links are black... the logo is similar but now the letters are black... this is the alt logo right?  So big question is why are the links a different color for this page?  

    I am looking in the page at override global settings and custom css but not seeing anything...

    I would love to get some pages looking like this(pages with white headers) and others with darker headers looking like what I asked in the original post.(understand this now, thanks a million)

    Thanks... you have been super helpful...

    Attached files:  3BACAC78-6E08-41DF-A995-F61A7F35116D.png

  • Travis replied

    after further thought on it... basically i am asking if there is a “switch” 

    for light/dark 

    for the nav bar

    On a page by page basis...

    Because some pages have the light links at the top and some have dark... the sticky header seems to be light at all times

  •  630
    Support Agent replied

    Hi Travis,

    The thing is that second page doesn't have alt logo added - http://shopscape.bold-themes.com/application/inner-page/features/.

    The alt logo is not added to Customization panel by default, but the homepage has it added to Override Global Settings.

    So, what you can do is to, either add alt logo to Override Global Settings of those pages where you have dark background, so the menu would be white, or you can simply change menu color with custom CSS.

    .menuPort nav > ul > li > a {
        color: #fff !important;
    }
    

    Let us know if you need additional help.

    Regards, BoldThemes team

    If you like our products please consider leaving us a rating. A huge thank you from BoldThemes in advance!

  • Travis replied

    ok... the big issue is keeping the logo the sticky header uses consistent.

    I only have one image I want to use in the sticky header and either way I switch it around that seems to change.

    So one page looks fine but the other is wrong or vice versa.

    On a dark page I want

    1. light logo

    2. sticky header has colored logo

    On the light page I want both to be the colored logo.....

    I am trying to fool around with override global settings but I cant find any documentation to understand what to input in the textboxes.  I appreciate your patience with this....

    [EDIT: found this on the forum:

    http://documentation.bold-themes.com/addison/theme-customization/

    ]

    [EDIT:  It doesn't seem to work though... I enter my logo ID for example and for logo it tries to load image like this...]

    http://2077

    In addition ALL PAGES seem to be using the alt-logo in header for some weird reason.  Even though the invert checkbox is not ticked.

    Like it never gets the address... so weird... 

      Cheers

  •  630
    Support Agent replied

    Hi Travis,

    Please try adding the link to logo in Override Global Settings in the following form.

    /wp-content/uploads/sites/2/2016/04/logo.png
    

    Let us know if this helped.

    Regards, BoldThemes team

    If you like our products please consider leaving us a rating. A huge thank you from BoldThemes in advance!

  • Travis replied

    thanks... that works but the spacing is not right on mobile so i think i will just go a different route.Thanks a lot though.

  •  630
    Support Agent replied

    Hi Travis,

    Glad if we could help!

    Please let us know if you need additional assistance.

    Regards, BoldThemes team

    If you like our products please consider leaving us a rating. A huge thank you from BoldThemes in advance!